add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Low Fps for the components I have

Bera
  • 41 months ago

I bought a gtx 1070 , i7 6700k , put it in a z170 board with a pretty good watercooler . Also 16gb of 2133mhz ram . Power supply provides 650w . Im currently playing on an old monitor until i get a new one , resolution being 1280x1024 . I added +350 to the gpu clock as it doesnt let me to put more or else it crashes , i dont know how much to add to memory . I couldnt overclock my cpu , i still need help with that , but the mobo keeps it at 4.4ghz anyways , so i shouldnt see a lot of performance for +0.2 or +0.3 ghz . Why am i seeing such low fps considering the resolution ? Heres some games i tested : Mafia 3 always around 60 fps , i know its a gpu intensive game so i should see way more fps considering it could be played in 2560x1440p at around 60 Gta 5 , in online , i cant get more than 90 and its normally around 90 , but falls down to 45 sometimes . heres the video which scares me https://www.youtube.com/watch?v=WhzPvddIkz8 The forest - around 90 fps too Cs go - I know this is a cpu intensive game , and here i get normal fps , it varies from 250-550 .

I really dont know why im seeing low fps in other games and in others its fine (cs go is doing quite nice , but i heard some can get constant 450fps , altough i obv dont care about this game , if im over 250fps im more than fine) . so , what have i done wrong ? Im thinking that i connected the gpu wrong : I see that the cable has 2 parts , one of them is not connected to anything and its just laying there . I can send a picture altough i dont know how to post it here . Rather than that , i dont see where i could've fked up

Comments

  • 41 months ago
  • 1 point

I really dont know why im seeing low fps

What do you get when all this overclocked is turned off??

Im currently playing on an old monitor

how old and what is it?

Mafia III is a ***** to play at highest settings. Just horrible at 4K

what scares you most about that youtube video :)

  • 41 months ago
  • 2 points

Hey don't mock youtube can be very scary if you don't believe me just watch home alone.

  • 41 months ago
  • 1 point

wtf are you talking about

  • 41 months ago
  • 1 point

Its called humour oh and Happy new year.

  • 41 months ago
  • 1 point

I sincerely dont see any big improvements from oc'ing , but i havent done exact tests so yeah . I told you , it matters that the monitor is 1280x1024 and im seeing low fps for that resolution It scares me that im seeing lower fps than i should . Im thinking that i might have connected the gpu wrong , the pcie connector is split into 2 hearders and one of them is actually just laying not connected to anything (i havent done the pc myself , some guys did it for me)

  • 41 months ago
  • 1 point

resolution being 1280x1024

your resolution does not match the game setting options for screen resolution. that could be problem 1

  • 41 months ago
  • 1 point

Nope . Same resolutions . what else ? How can i post a picture so i can show u what i think that could cause the problem : and that being how i connected the gpu ?

  • 41 months ago
  • 1 point

give me model number of your monitor and video card. I can look it up

  • 41 months ago
  • 1 point

Im talking about how i connected the gpu to my psu

  • 41 months ago
  • 1 point

It straight up wouldn't work if you didn't have it powered.

  • 41 months ago
  • 1 point

Well . its connected with a cable thats split into two , one of the cables not being connected to anything , i dont think thats the problem , but i wanna make sure . I dont know why else i'd see such low fps

  • 41 months ago
  • 1 point

did you post your model number of power supply?

  • 41 months ago
  • 1 point

That video stinks. There is no proof of his settings or his FPS. Make sure windows has done all its million updates and all the drivers are finished updating. For a few hours on a new build, windows really sucks up the resources.
After everything is stabilized, run 3DMark benchmark like Firestrike or Timespy the compare your scores to similar set ups.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube