add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Logitech G430 issue

waj287

3 months ago

So lately, I've had issues with my G430s continually connecting and disconnecting. It makes the Windows 10 device connect/disconnect sound play constantly.

Anyone have any fixes?

Comments

  • 3 months ago
  • 1 point

Reinstall logitech/sound drivers. If you are using the USB adapter that came with it I would try switching just to the 3.5mm jacks. I also wouldn't buy this headset again, I had a problem that apparently happens with g430s a lot where the right earpiece just falls off.

  • 3 months ago
  • 1 point

Okay then. Will try later. To make sure do I plug the headphones into the green port and the mic into the pink one? (Not that big of an audio guy so I don't really know)

Thanks for the help!

  • 3 months ago
  • 1 point

if the ports have colors those are the standard colors. :)

(sometimes they have several of them the same color if the mobo is trying to look cool. Looking at you my old MSI gaming 5 z97. haha)

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube