add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

My h80i is glowing red, and says that the cpu is 84 degrees f, off start up????????????

lokiinsane

77 months ago

I have a asus thunderbolt mobo, intel i7 3770k, h80i cpu cooler, evga gtx 680 classified edt 4gb gpu, 2x 16 gb corsair vengeance memory. I don't have anything overclocked yet because i don't need to. Ive only had this build up for 2 months and just noticed this the other day. Fans work just the same as before, the only thing Ive noticed different is the led corsair light changed from blue to red. My cpu used to run around the low 40 degree f. range Someone please help. Ive tried seating the heat-sink better, nothing. I vacuumed out my case, nothing. I haven't replaced the thermal paste yet. Some one smarter then me PLEASE HELP!!!!!!!!!!!!

Comments

  • 77 months ago
  • 1 point

Download realtemp and check the temperature there, it could be a problem with the CPU Cooler's thermometer, if it doe snot work still i'd suggest replacing the CPU cooler to the stock cooler temporarily until you find out what the problem is.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube